win7系统下载
当前位置: 首页 > 网络技术教程 > 详细页面

思科固定ip上网及pppoe方式上网设置

发布时间:2020-03-25 文章来源:xp sp3系统下载 浏览:

网络技术是从1990年代中期发展起来的新技术,它把互联网上分散的资源融为有机整体,实现资源的全面共享和有机协作,使人们能够透明地使用资源的整体能力并按需获取信息。资源包括高性能计算机、存储资源、数据资源、信息资源、知识资源、专家资源、大型数据库、网络、传感器等。 当前的互联网只限于信息共享,网络则被认为是互联网发展的第三阶段。

本文主要从网络接口配置和DHC匹配值等技术方面详细的介绍了如何实现思科固定IP上网和PPPOE的上网配置,详细介绍请看下面文章。

现有客户需要使用思科的2600路由器上网,用户为10M光纤,申请了16个固定IP,ip为61.161.xxx.2-61.161.xxx.14,默认网关是61.161.xxx.1.内网ip段192.168.1.0,客户要实现192.168.1.50-192.168.1.60之间的ip可以上网,其余的不可以。

路由器e0/0接口为外网接口,e0/1为内网接口

interface e0/0

ip address 61.161.xxx.2 255.255.255.240 //这里可以使用61.161.xxx.2-14个地址中的任意一个,这里就用2

ip nat outside

full-duplex

interface e0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

full-duplex

access-list 1 permit host 192.168.1.50

access-list 1 permit host 192.168.1.51

access-list 1 permit host 192.168.1.52

access-list 1 permit host 192.168.1.53

access-list 1 permit host 192.168.1.54

access-list 1 permit host 192.168.1.55

access-list 1 permit host 192.168.1.56

access-list 1 permit host 192.168.1.57

access-list 1 permit host 192.168.1.58

access-list 1 permit host 192.168.1.59

access-list 1 permit host 192.168.1.60

ip nat pool intoout 61.161.xxx.2 61.161.xxx.2 netmask 255.255.255.240 //这里复用61.161.xxx.2的地址,也可以这样写:ip nat pool intoout 61.161.xxx.2 61.161.xxx.14 netmask 255.255.255.252 这样写之后,从地址池里选择任意可用的外网ip 转换。

ip nat inside source list 1 pool intoout Overload

ip route 0.0.0.0 0.0.0.0 61.161.xxx.1 //默认网关,即电信端的地址,下一条地址。

这样配置后就可以上网了,但是客户端必须设置固定ip,配置DNS,如果不配置,因为没有开启DHCP服务,所以必须设置固定IP。

网络的神奇作用吸引着越来越多的用户加入其中,正因如此,网络的承受能力也面临着越来越严峻的考验―从硬件上、软件上、所用标准上......,各项技术都需要适时应势,对应发展,这正是网络迅速走向进步的催化剂。

本文章关键词: 路由器 配置